WordPress feed Atom 1.0

Andando avanti con lo sviluppo di Blog Validator, il prossimo passo sarà quello di inserire il controllo di validità dei feed.

Facendo qualche prova però, mi sono accorto che WordPress (anche nell’ultima versione, la 2.0.7) utilizza ancora la versione di Atom 0.3 che il validatore del W3c reputa obsoleta.

Ho cercato qualche informazione in più su Google ed ho trovato questa soluzione: un blogger ha creato una versione aggiornata di wp-atom.php e wpcommentsatom.php che portano la versione di Atom dalla 0.3 alla 1.0.

I file si trovano qui e vanno inseriti nella directory principale di WordPress, ma, come fa notare l’autore, funzionano solo se il server php è aggiornato alla versione 5.*. Per chi, come me, ha ancora PHP4, entra in gioco la patch di nlindblad, che risolve il problema. Potete scaricarla da qui e se avete un accesso shell al server vi basterà eseguire il comando patch wp-atom.php < wp-atom.patch per completare l’opera.

Per chi non dovesse avere accesso alla shell le modifiche da effettuare, dopo aver cambiato i file sono le seguenti:

Sostituire la riga 22:

con la seguente:

E poi le righe 37 e 38:

< ?php the_time('c'); ?> < ?php the_time('c'); ?>

con le seguenti:

< ?php the_time('Y-m-d\TH:i:s\Z'); ?> < ?php the_time('Y-m-d\TH:i:s\Z'); ?>

In questo modo risolverete l’incompatibilità con PHP4.

A questo punto il vostro feed sarà aggiornato alla versione di Atom 1.0 e non riceverete più “brutte risposte” dal Feed Validator. 🙂

P|xeL

PS: dopo aver applicato la patch mi sono anche accorto (googlando ancora) che Simone Carletti (di cui vi consiglio di leggere i suoi suggerimenti per mantenere un feed) ne aveva segnalato l’esistenza sul forum di RSS World che a questo punto gli confermo esser funzionante.

6 commenti » Scrivi un commento

  1. Pingback: …time is what you make of it… » Archivio del blog » Aggiornamento a Wordpress 2.1

  2. Ringraziandoti per i preziosi riferimenti … ti segnalo una correzione da effettuare nei campi data & Time della patch : Y-m-dTH:i:sZ [questa è la giusta sintassi] puoi verificare la validità del feed Atom 1.0 dal footer del mio weblog 😮 inoltre è consigliabile modificare anche il campo title sul link rel presente in header [weblog] : alla voce Atom 0.3 con Atom 1.0

    Ad Maiora

    esav

  3. Pingback: enetweb » WordPress : How-To - Upgrade feed Atom 1.0

  4. Ciao Enore, nonostante il ritardo, la tua precisazione non è andata perduta. Ho effettuato le modifiche anche al post in modo da divulgare la sintassi corretta.
    Grazie per l’attenzione. 🙂
    P|xeL

  5. Pingback: Wordpress 2.2 su …time is what you make of it…

Lascia un commento

I campi richiesti sono marcati con *.


Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.