Ubuntu: CIFS VFS server not responding.

Continuo giornalmente ad ottimizzare ciò che non va su Ubuntu. Questa volta il problema si presentava durante il reboot.

CIFS VFS: Server not responding

CIFS VFS: No response for cmd 20 mid 11589

Il seguente errore appare perché il NetworkManager, durante le operazioni di chiusura, viene terminato prima che siano smontate le condivisioni Samba.

Per ovviare al problema, basta modificare la priorità in rc6.d al file S31umountnfs.sh.

Procediamo dunque come segue:

cd /etc/rc6.d
sudo mv S31umountnfs.sh S14umountnfs.sh

Tutto qui. Al prossimo riavvio i dischi verranno smontati correttamente e non incontreremo nuovamente errori (che allungavano di molto i tempi di reboot).

Emanuele

7 commenti » Scrivi un commento

  1. Ciao Emanuele,
    anch’io ho problemino allo shout-down del sistema, sia che si voglia riavviare che spegnere.
    Ho l’abitudine di staccare sempre il cavetto ADSL allo spegnimento del PC, dato che in passato mi è capitata la sventura di sostituire un modem ADSL perché bruciato da una scossa di elettricità, provocata sicuramente da un fulmine.
    Se stacco questo cavetto e poi spengo il PC, i tempi di spegnimento di allungano a dismisura, in caso contrario funziona tutto correttamente.
    Mi sapresti dire se anche questo problema è riferibile a quello che dici nel post, sapendo che non uso samba??

    Ciao

  2. Beh in realtà si allungano perché tenta di disattivare una periferica che non risponde. Perché non stacchi il cavetto DOPO che il computer si sia spento, in modo da permetterne la rimozione corretta?! 😮
    Comunque se hai problemi di sbalzi di tensione, ti consiglio una ciabatta con fusibile: una volta è successo al modem, nulla dice che non possa succedere al monitor o al computer stesso… 😐
    Ciao,
    Emanuele

  3. Beh, veramente lo faccio già… quello di staccare il cavetto telefonico dopo. 😛 E non uso il PC se non ho un UPS, il quale alimenta tutto il resto: dalle casse fino alla stampante. 😉

    Ciao

  4. E allora perché quella domanda?! 😮
    Staccalo sempre dopo, no? Lascia la possibilità al sistema di smontare tutte le periferiche correttamente…! 😐
    Quanti watt è il tuo UPS?! Il mio è morto… dovrei cambiare la batteria ma sto valutando se prendere qualcosa di più grosso… 🙂
    Ciao,
    Emanuele

  5. Ho fatto quella domanda perché non mi avevo questi problemi con Ubuntu 8.10. 😐

    Il mio è di 750watt, ma anche a me la batteria non regge più, neanche un secondo pieno.

    Anch’io dovrei cambiarlo sempre con uno da 750, per me basta ed avanza. 😉

    Notte 🙂

  6. Ciao,
    il commento precedente lascia un po’ a desiderare ed ho anche sbagliato! :timid:

    Volevo dire che prima della 8.10 avevo la 8.04 e non avevo tale problema, veramente ancora prima avevo Mandriva e neanche lì avevo problemi… dunque, mi sembrava strano questo comportamento del sistema di rete.

    Ora si capisce meglio… dopo una bella dormita. 😀

    Ciao

Lascia un commento

I campi richiesti sono marcati con *.


This site uses Akismet to reduce spam. Learn how your comment data is processed.